Skip to main content

Services for Students: Browser Requirements

The UHV Library offers a number of services to students

Browser Requirements

Library databases often require an up-to-date browser. We recommend the following:

  • For Internet Explorer, Version 11 or higher
  • For Firefox, Version 10 or higher
  • For Chrome, Version 18 or higher
  • For Safari, Version 5 or higher

Other Browser Settings

Some databases require javascript and / or cookies to be enabled. Here are links to instructions on how to check your settings

There are some library databases that do NOT work in Internet Explorer.
Enable Javascript
Enable Cookies